首页 编程设计易语言正文

易语言去广告软件制作讲解

云水 易语言 2020-05-10 11:55:21 916 0 易语言

该程序使用到了最新的精易模块V3.68,跟程序平行的有个closeProcess.txt用来配置需要关闭的广告后台进程。支持腾讯视频客户端、PPS客户端、PPTV客户端等一些主流的视频客户端的广告屏蔽,再也不用担心观看视频有60秒的广告了。

首先是界面

image.png

给程序添加一个时钟,两个按钮,时钟用来控制循环监听任务管理器的进程,主要思想:遇到广告后台程序,强制关掉。

界面代码


.版本 2
 
.程序集 窗口程序集1
 
.子程序 __启动窗口_创建完毕
.局部变量 目录, 文本型
.局部变量 文件ID, 整数型
.局部变量 内容, 文本型
  
目录 = 取运行目录 ()
.如果真 (文件是否存在 (目录 + “/closeProcess.txt”) = 假)
  信息框 (“找不到closeProcess.txt文件!”, 0, )
.如果真结束
文件ID = 打开文件 (目录 + “/closeProcess.txt”, , )
内容 = 读入一行 (文件ID)
.判断循环首 (内容 ≠ “”)
  加入成员 (进程数组, 内容)
  内容 = 读入一行 (文件ID)
.判断循环尾 ()
' 信息框 (取数组成员数 (进程数组), 0, )
关闭文件 (文件ID)
关闭进程 ()
' 时钟1.时钟周期 = 5000
_按钮1_被单击 ()
 
.子程序 关闭进程
.局部变量 i, 整数型
.局部变量 进程ID, 整数型
 
.变量循环首 (1, 取数组成员数 (进程数组), 1, i)
  进程ID = 进程_名取ID (进程数组 [i])
  .如果真 (进程ID ≠ 0)
    进程_结束 (进程ID)
  .如果真结束
 
.变量循环尾 ()
 
.子程序 _按钮1_被单击
 
时钟1.时钟周期 = 5000
标签1.标题 = “程序监听中...”
 
.子程序 _时钟1_周期事件
 
关闭进程 ()
 
.子程序 _按钮2_被单击
 
时钟1.时钟周期 = 0
标签1.标题 = “程序监听取消了...”
 
.子程序 __启动窗口_托盘事件
.参数 操作类型, 整数型
 
.如果真 (操作类型 = 2) ' 操作类型2双击托盘图标
  可视 = 真
  位置 = 1
  置托盘图标 ({ }, “”)
.如果真结束
  
.子程序 __启动窗口_位置被改变
 
.如果真 (位置 = 2) ' 位置2窗口最小化
  置托盘图标 (#图片1, “noAd”)
  可视 = 假
.如果真结束


全局变量


.版本 2
 
.全局变量 进程数组, 文本型, , "0"

图标文件

添加一个图标文件以便于最小化到托盘

.版本 2
 
.图片 图片1

以上就是全部相关内容,感谢大家对脚本之家的支持。


版权声明

1.本站大部分下载资源收集于网络,不保证其完整性以及安全性,请下载后自行测试。
2.本站资源仅供学习和交流使用,版权归资源原作者所有,请在下载后24小时之内自觉删除。
3.若作商业用途,请购买正版,由于未及时购买和付费发生的侵权行为,与本站无关。
4.若内容涉及侵权或违法信息,请联系本站管理员进行下架处理,邮箱ganice520@163.com(本站不支持其他投诉反馈渠道,谢谢合作)

本文链接:http://u256.cn/index.php/post/390.html

发表评论

评论列表(0人评论 , 916人围观)
☹还没有评论,来说两句吧...